View Issue Details

IDCategoryLast Update
0008418bugs2020-09-23 19:24
ReportergedobblesAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.3 
Fixed in Version 
Summary0008418: Ardour crashes on start
DescriptionArdour crashes on start.
terminal output is attached
Steps To Reproducestart Ardour with
$ ardour6

then select to open any or a new project.

This bug also occurs when the configuration in ~/.config/ardour6 is removed.
Additional InformationThe crash is related to libs/ardour/disk_reader.cc:1665 as the log indicates:

assert (n < loop_fade_length);

however n IMO can be equal to loop_fade_length after the preceding

for(n = 0;(n < loop_fade_length) && (g > GAIN_COEFF_DELTA); ++n) {...} or similar

loop in certain configurations of GAIN_COEFF_DELTA.

Samplerate is 192000 S/s.
Tagscrash

Activities

gedobbles

2020-09-22 14:19

reporter  

ardour_terminal_output.txt (5,028 bytes)
$ ardour6
bind txt domain [gtk2_ardour6] to /usr/local/share/ardour6/locale
Ardour6.3.0 (built using 6.3 and GCC version 7.5.0)
Ardour: [INFO]: Your system is configured to limit Ardour to 1048576 open files
Ardour: [INFO]: Loading system configuration file /usr/local/etc/ardour6/system_config
Ardour: [INFO]: Loading user configuration file /home/aoei/.config/ardour6/config
Ardour: [INFO]: CPU vendor: AuthenticAMD
Ardour: [INFO]: AVX-capable processor
Ardour: [INFO]: CPU brand: AMD Ryzen 7 3800X 8-Core Processor             
Ardour: [INFO]: Using AVX optimized routines
Ardour: [INFO]: Loading plugin meta data file /usr/local/share/ardour6/plugin_metadata/plugin_tags
Ardour: [INFO]: Loading plugin statistics file /home/aoei/.config/ardour6/plugin_metadata/plugin_stats
Ardour: [INFO]: Loading default ui configuration file /usr/local/etc/ardour6/default_ui_config
Ardour: [INFO]: Loading user ui configuration file /home/aoei/.config/ardour6/ui_config
Ardour: [INFO]: Loading 449 MIDI patches from /usr/local/share/ardour6/patchfiles
/usr/share/themes/Lubuntu-default/gtk-2.0/apps/pcmanfm.rc:29: error: unexpected identifier 'hint', expected character '}'
Ardour: [INFO]: Loading color file /usr/local/share/ardour6/themes/dark-ardour.colors
/usr/share/themes/Lubuntu-default/gtk-2.0/apps/pcmanfm.rc:29: error: unexpected identifier 'hint', expected character '}'
Ardour: [INFO]: Loading ui configuration file /usr/local/etc/ardour6/clearlooks.rc
Ardour: [INFO]: Loading bindings from /home/aoei/.config/ardour6/ardour.keys
Loading ui configuration file /usr/local/etc/ardour6/clearlooks.rc

(ardour-6.3.0:2613): GLib-GIO-CRITICAL **: 10:32:58.675: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
Found nothing along /home/aoei/.config/ardour6/templates:/usr/local/share/ardour6/templates
pingback: No Error
lilv_world_load_bundle(): warning: Ignoring bundle <file:///usr/lib/lv2/a-eq.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-eq> loaded from <file:///usr/local/lib/ardour6/LV2/a-eq.lv2/>
lilv_world_load_bundle(): warning: Ignoring bundle <file:///usr/lib/lv2/a-fluidsynth.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-fluidsynth> loaded from <file:///usr/local/lib/ardour6/LV2/a-fluidsynth.lv2/>
lilv_world_load_bundle(): warning: Ignoring bundle <file:///usr/lib/lv2/a-reverb.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-reverb> loaded from <file:///usr/local/lib/ardour6/LV2/a-reverb.lv2/>
lilv_world_load_bundle(): warning: Ignoring bundle <file:///usr/lib/lv2/a-comp.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-comp> loaded from <file:///usr/local/lib/ardour6/LV2/a-comp.lv2/>
lilv_world_load_bundle(): warning: Ignoring bundle <file:///usr/lib/lv2/a-delay.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-delay> loaded from <file:///usr/local/lib/ardour6/LV2/a-delay.lv2/>
lilv_world_add_plugin(): warning: Duplicate plugin <https://community.ardour.org/node/7596>
lilv_world_add_plugin(): warning: ... found in file:///usr/local/lib/ardour6/LV2/reasonablesynth.lv2/
lilv_world_add_plugin(): warning: ... and      file:///usr/lib/lv2/reasonablesynth.lv2/ (ignored)
Scanning folders for bundled LV2s: /usr/local/lib/ardour6/LV2
lilv_world_load_bundle(): warning: Ignoring bundle <file:///usr/lib/lv2/a-eq.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-eq> loaded from <file:///usr/local/lib/ardour6/LV2/a-eq.lv2/>
lilv_world_load_bundle(): warning: Ignoring bundle <file:///usr/lib/lv2/a-fluidsynth.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-fluidsynth> loaded from <file:///usr/local/lib/ardour6/LV2/a-fluidsynth.lv2/>
lilv_world_load_bundle(): warning: Ignoring bundle <file:///usr/lib/lv2/a-reverb.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-reverb> loaded from <file:///usr/local/lib/ardour6/LV2/a-reverb.lv2/>
lilv_world_load_bundle(): warning: Ignoring bundle <file:///usr/lib/lv2/a-comp.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-comp> loaded from <file:///usr/local/lib/ardour6/LV2/a-comp.lv2/>
lilv_world_load_bundle(): warning: Ignoring bundle <file:///usr/lib/lv2/a-delay.lv2/>
lilv_world_load_bundle(): note: Newer version of <urn:ardour:a-delay> loaded from <file:///usr/local/lib/ardour6/LV2/a-delay.lv2/>
lilv_world_add_plugin(): warning: Duplicate plugin <https://community.ardour.org/node/7596>
lilv_world_add_plugin(): warning: ... found in file:///usr/local/lib/ardour6/LV2/reasonablesynth.lv2/
lilv_world_add_plugin(): warning: ... and      file:///usr/lib/lv2/reasonablesynth.lv2/ (ignored)
Set cursor set to default
 loading from /home/aoei/Musik/ardour/Untitled-2020-09-22-10-33-01 as Untitled-2020-09-22-10-33-01 templ  is_new 1 bp 2
ardour-6.3.0: ../libs/ardour/disk_reader.cc:1671: void ARDOUR::DiskReader::Declicker::alloc(ARDOUR::samplecnt_t, bool): Zusicherung »n < loop_fade_length« nicht erfüllt.
Abgebrochen (Speicherabzug geschrieben)

x42

2020-09-22 14:46

administrator   ~0025049

This should be fixed since 6.3-74-gecf4a62082

Only debug builds were be affected, and the issue was only present if you use an insane sample-rate (> 96kHz).

gedobbles

2020-09-22 14:49

reporter   ~0025050

As 6.3-74-gecf4a62082 is not tagged in git, is it stable to run?
And with what should one replace ./waf so the result is not a debug build?

x42

2020-09-23 19:24

administrator   ~0025053

./waf configure --optimize ....
./waf

Compare to https://nightly.ardour.org/i/A_Linux_x86_64-gcc5abi/build_log.txt

Issue History

Date Modified Username Field Change
2020-09-22 14:19 gedobbles New Issue
2020-09-22 14:19 gedobbles File Added: ardour_terminal_output.txt
2020-09-22 14:33 gedobbles Tag Attached: crash
2020-09-22 14:46 x42 Assigned To => x42
2020-09-22 14:46 x42 Status new => resolved
2020-09-22 14:46 x42 Resolution open => fixed
2020-09-22 14:46 x42 Note Added: 0025049
2020-09-22 14:49 gedobbles Note Added: 0025050
2020-09-23 19:24 x42 Note Added: 0025053