View Issue Details

IDCategoryLast Update
0008459bugs2021-07-16 21:04
ReporterpdecheryAssigned Tox42 
Reproducibilityrandom 
Status closedResolutionfixed 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.3 
Fixed in Version 
Summary0008459: Ardour crashing with message GUI POOL OUT OF MEMORY
DescriptionI recently downloaded the new version (1 month ago) and I'm getting repeated crashes where I'm shown the message below in an alert box:

"CRITICAL: GUI POOL OUT OF MEMORY - RECOMPILE WITH LARGER SIZE"

Trying to reproduce the bug I notice it happens when I start to edit a MIDI track. More specifically, when I try to edit velocity in MIDI notes. If I work on audio tracks, nothing happens.

I begun a project recently and worked entire days without crashes. Went for edit some MIDI notes and the crashes started again.


Steps To ReproduceCreate MIDI track, add notes and change velocities. Not sure yet this is the main cause, but right now it is to me.
TagsNo tags attached.

Activities

pdechery

2020-10-27 11:01

reporter  

pdechery

2020-10-27 11:19

reporter   ~0025166

Is it possible to edit the issue?

I forgot to inform my OS version, which is 20.04.

pdechery

2020-10-27 11:45

reporter   ~0025168

I did a few tests and noticed the bug happens when you try to change the velocity of a MIDI note through the mouse (clicking the note and scrolling with the mouse tracker) .

If you edit the velocity in the "Edit" window, right-clicking the MIDI note, nothing happens.

Since I did this in Ardour 5 without any problems I guess the bug is related to the new features added in 6.3, regarding MIDI notes. For example, in the new version the velocity of a note is shown as a little bar inside the note and changes width dinamically, as we roll with the mouse.

x42

2020-10-27 16:49

administrator   ~0025170

The underlying issue is that the GUI queues up events for others to process. But you produce events faster than others (backend, ctrl surfaces etc) can process them.

Do you perhaps have any Ctrl surfaces enabled (Preferences > Control Surfaces > ...)

Then again repeat MIDI edits might also be able to trigger this, if re-reading the MIDI files takes too long.

pdechery

2020-10-27 17:54

reporter   ~0025172

Hi, thanks for answering.

"Do you perhaps have any Ctrl surfaces enabled (Preferences > Control Surfaces > ...)"

No, i wasn't even aware of that option.

gaurangarora

2021-04-21 18:55

reporter   ~0025726

It can be reproduced without MIDI too.
Import a long single file recording, for example a voice over recording, more than 30-40 minutes.

Attempt to strip silence reproduces this error. Also attempting to normalise a lot many regions results in the same error.

2021-04-22_00-23.png (131,349 bytes)
2021-04-22_00-23.png (131,349 bytes)

gaurangarora

2021-07-16 19:29

reporter   ~0026053

No longer facing this Issue with version versions 6.7 and 6.8

x42

2021-07-16 21:04

administrator   ~0026054

Good to know. Likely fixed in the 6.6 -> 6.7 dev cycle along with similar issues:
https://tracker.ardour.org/view.php?id=8626 and https://tracker.ardour.org/view.php?id=8576

anonymous

2021-07-16 21:04

viewer   ~0026055

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-10-27 11:01 pdechery New Issue
2020-10-27 11:01 pdechery File Added: Screenshot from 2020-10-27 07-44-07.png
2020-10-27 11:19 pdechery Note Added: 0025166
2020-10-27 11:45 pdechery Note Added: 0025168
2020-10-27 16:49 x42 Note Added: 0025170
2020-10-27 17:54 pdechery Note Added: 0025172
2021-04-21 18:55 gaurangarora File Added: 2021-04-22_00-23.png
2021-04-21 18:55 gaurangarora Note Added: 0025726
2021-07-16 19:29 gaurangarora Note Added: 0026053
2021-07-16 21:04 x42 Note Added: 0026054
2021-07-16 21:04 x42 Assigned To => x42
2021-07-16 21:04 x42 Status new => resolved
2021-07-16 21:04 x42 Resolution open => fixed
2021-07-16 21:04 anonymous Note Added: 0026055
2021-07-16 21:04 anonymous Status resolved => closed