View Issue Details

IDCategoryLast Update
0008510bugs2021-02-18 17:05
ReporterjegelieAssigned Tox42 
Reproducibilityalways 
Status closedResolutionreopened 
PlatformApple MacintoshOSMacOSOS Version10.12 or later
Product Version6.5 
Fixed in Version 
Summary0008510: Waves V12 plugin interface mirrored
DescriptionWhen opening a V12 plugin of Waves in either AU or VST3 format, the interface is mirrored upside down.
Steps To ReproduceOpen Waves V12 plugin interface in Ardour.
In any other host it is not mirrored.
Additional InformationI checked the resource bundles; there is a PNG.zip package in each of these plugins. I suspect a wrong interpretation of each PNG file, possibly due to PNG graphics library coordinate handling. At the risk of violating copyright and other licenses, I will not include any of the PNG, only screenshots (how it is on Ardour 6.5 Mac, how it is supposed to be).
TagsAudio Unit, Metal, VST3

Activities

jegelie

2020-12-20 16:57

reporter  

Right interface on Hosting AU.PNG (335,369 bytes)
Wrong interface on Ardour.PNG (289,838 bytes)

jegelie

2020-12-20 17:04

reporter   ~0025332

However I have done an ImageMagick identify -verbose analysis on one PNG for further investigation. Text output is attached.

WavesPNG_identify_verbose.txt (2,720 bytes)
Image: /Users/jegelie/Desktop/PNG_/616.png
  Format: PNG (Portable Network Graphics)
  Mime type: image/png
  Class: DirectClass
  Geometry: 44x15+0+0
  Units: Undefined
  Colorspace: sRGB
  Type: GrayscaleAlpha
  Base type: Undefined
  Endianess: Undefined
  Depth: 8-bit
  Channel depth:
    red: 8-bit
    green: 8-bit
    blue: 8-bit
    alpha: 1-bit
  Channel statistics:
    Pixels: 660
    Red:
      min: 35  (0.137255)
      max: 180 (0.705882)
      mean: 63.1212 (0.247534)
      standard deviation: 57.3739 (0.224996)
      kurtosis: 0.386566
      skewness: 1.54466
      entropy: 0.70964
    Green:
      min: 35  (0.137255)
      max: 180 (0.705882)
      mean: 63.1212 (0.247534)
      standard deviation: 57.3739 (0.224996)
      kurtosis: 0.386566
      skewness: 1.54466
      entropy: 0.70964
    Blue:
      min: 35  (0.137255)
      max: 180 (0.705882)
      mean: 63.1212 (0.247534)
      standard deviation: 57.3739 (0.224996)
      kurtosis: 0.386566
      skewness: 1.54466
      entropy: 0.70964
    Alpha:
      min: 255  (1)
      max: 255 (1)
      mean: 255 (1)
      standard deviation: 0 (0)
      kurtosis: -3.2768e+64
      skewness: 9.375e+44
      entropy: 0
  Image statistics:
    Overall:
      min: 35  (0.137255)
      max: 255 (1)
      mean: 111.091 (0.435651)
      standard deviation: 43.0304 (0.168747)
      kurtosis: -1.51115
      skewness: 0.580132
      entropy: 0.53223
  Colors: 2
  Histogram:
       532: ( 35, 35, 35,255) #232323FF srgba(35,35,35,1)
       128: (180,180,180,255) #B4B4B4FF srgba(180,180,180,1)
  Rendering intent: Perceptual
  Gamma: 0.454545
  Chromaticity:
    red primary: (0.64,0.33)
    green primary: (0.3,0.6)
    blue primary: (0.15,0.06)
    white point: (0.3127,0.329)
  Background color: white
  Border color: srgba(223,223,223,1)
  Matte color: grey74
  Transparent color: none
  Interlace: None
  Intensity: Undefined
  Compose: Over
  Page geometry: 44x15+0+0
  Dispose: Undefined
  Iterations: 0
  Compression: Zip
  Orientation: Undefined
  Properties:
    date:create: 2020-12-20T17:50:32+01:00
    date:modify: 2020-08-10T18:24:44+02:00
    png:IHDR.bit-depth-orig: 8
    png:IHDR.bit_depth: 8
    png:IHDR.color-type-orig: 6
    png:IHDR.color_type: 6 (RGBA)
    png:IHDR.interlace_method: 0 (Not interlaced)
    png:IHDR.width,height: 44, 15
    png:sRGB: intent=0 (Perceptual Intent)
    signature: 0318e8d293215ed3795d8935f348687d2dcc52b30a3450a215d1a9cfa138e658
  Artifacts:
    filename: /Users/jegelie/Desktop/PNG_/616.png
    verbose: true
  Tainted: False
  Filesize: 157B
  Number pixels: 660
  User time: 0.000u
  Elapsed time: 0:01.000
  Version: ImageMagick 6.9.9-40 Q16 x86_64 2018-12-13 http://www.imagemagick.org

x42

2020-12-20 17:31

administrator   ~0025334

It's not an Ardour, issue. The same happen in other hosts (Reaper, ProTools) also some windows systems are affected:

https://forum.waves.com/t/plug-ins-gui-upside-down/2148/3

jegelie

2020-12-20 19:59

reporter   ~0025335

Hmmm... I didn't do my research thoroughly then. Case closed.

jegelie

2020-12-28 10:40

reporter   ~0025365

Delving deeper, I got word back from Waves' Tech Support. Seams they render the V12 GUI by *only* using Apple's Metal frameworks. My question now is: how are graphics rendered by Metal calls handled by the Ardour viewports? I think Waves just set a precedent here, if other plugin developers decide to switch over to Metal, this could get messy...

anonymous

2021-02-18 16:58

viewer   ~0025528

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

x42

2021-02-18 17:05

administrator   ~0025529

Ardour doesn't care or is nonthewiser. In both cases (AU, VST3) the plugin provides Ardour with an "NSView". The plugin host is ignorant about the technology used to render that.

Issue History

Date Modified Username Field Change
2020-12-20 16:57 jegelie New Issue
2020-12-20 16:57 jegelie Tag Attached: Audio Unit
2020-12-20 16:57 jegelie Tag Attached: VST3
2020-12-20 16:57 jegelie File Added: Right interface on Hosting AU.PNG
2020-12-20 16:57 jegelie File Added: Wrong interface on Ardour.PNG
2020-12-20 17:04 jegelie File Added: WavesPNG_identify_verbose.txt
2020-12-20 17:04 jegelie Note Added: 0025332
2020-12-20 17:31 x42 Note Added: 0025334
2020-12-20 19:59 jegelie Note Added: 0025335
2020-12-20 20:05 x42 Assigned To => x42
2020-12-20 20:05 x42 Status new => closed
2020-12-20 20:05 x42 Resolution open => no change required
2020-12-28 10:40 jegelie Status closed => feedback
2020-12-28 10:40 jegelie Resolution no change required => reopened
2020-12-28 10:40 jegelie Note Added: 0025365
2020-12-28 10:46 jegelie Tag Attached: Metal
2021-01-05 16:03 paul Status feedback => resolved
2021-02-18 16:58 anonymous Note Added: 0025528
2021-02-18 16:58 anonymous Status resolved => closed
2021-02-18 17:05 x42 Note Added: 0025529