View Issue Details

IDCategoryLast Update
0008529bugs2021-03-01 13:06
Reporterslash42Assigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformDebian GNUOSLinuxOS Version(any)
Product Version6.5 
Fixed in Version 
Summary0008529: Segfault when moving a wave region using the middle mouse button and also clicking the left mouse button
DescriptionI'm experiencing this bug for quite a while now, that sometimes Ardour crashes while I'm moving a wave region from one track to another. By coincidence, I think I found out how to trigger this bug in a deterministic way today.
So... I'm reporting it now.
Steps To Reproduce- open a blank session (sampling rate doesn't matter)
- add two wave tracks (mono or stereo doesn't matter)
- record something into one wave track (or import an existing wave file, it doesn't really matter)
- click and hold the middle mouse button on the recorded/imported region
- move the region to the second track but keep the middle mouse button pressed! (this is the important part)
- now, click also the left mouse button => a segfault will occur immediately
Additional InformationI'm able to reproduce this on three different boxes:
- Debian bullseye, Ardour 1:6.3.0+ds0-1
- Debian buster, Ardour 1:5.12.0-3
- KDE Neon / Ubuntu LTS (20.04), Ardour 1:5.12.0-3ubuntu4
TagsNo tags attached.

Activities

paul

2021-01-08 05:56

administrator   ~0025391

Should be fixed in git, commit 2596f0b1e2

paul

2021-01-18 17:48

administrator   ~0025433

no feedback from reporter, but almost certainly fixed.

anonymous

2021-03-01 13:06

viewer   ~0025573

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-12-31 13:05 slash42 New Issue
2021-01-05 16:31 paul Assigned To => paul
2021-01-08 05:56 paul Status new => feedback
2021-01-08 05:56 paul Note Added: 0025391
2021-01-18 17:48 paul Status feedback => resolved
2021-01-18 17:48 paul Resolution open => fixed
2021-01-18 17:48 paul Note Added: 0025433
2021-03-01 13:06 anonymous Note Added: 0025573
2021-03-01 13:06 anonymous Status resolved => closed