View Issue Details

IDCategoryLast Update
0008566features2021-02-18 00:10
ReporterahellquistAssigned To 
Reproducibilityhave not tried 
Status newResolutionopen 
PlatformGNUOSLinuxOS Version(any)
Product Version6.5 
Fixed in Version 
Summary0008566: We need a way to understand Blacklisting reasons..
DescriptionRight now U-he have released a new beta of Hive 2.1

The new beta works fine in Carla, Reaper Pre-release and probably Qtractor
It is however blacklisted by both Ardour 6.5 and Current Mixbus

We have reported this to U-he and they will look into the problem but the problem might be in Ardour/Mixbus and thats why it would be handy if there was a way for users to know the reason for why the plugin became balcklisted..

This is the thread where the blacklist problem is being discussed

https://www.kvraudio.com/forum/viewtopic.php?f=292&t=559970
Steps To ReproduceInstall U-he hive 2.1 beta..

Launch any host but Ardour/Mixbus

Profit
TagsBlacklist, u-he

Activities

x42

2021-02-07 22:32

administrator   ~0025497

A plugin is only blacklisted if it cannot be loaded or crashes when loaded into Ardour.
In case of u-he the most likely underlying cause that it cannot be loaded is because those plugins are not statically linked and produce symbol conflicts.

thebutant

2021-02-09 08:31

reporter   ~0025500

The blacklisting feature frustrates me quite a lot, as I (an otherwise very satisfied Mixbus 32C user - a true believer, so to say) no longer count on plugins to work in Mixbus/Ardour.
I see a new build (as the Hive 2.1) and get all excited, but also know that "well, it still remains to see if this works." And then, I feel it quite often doesn't.
In other hosts (Qtractor, Reaper, Carla are the ones I use and check), yes. But often not in Ardour/Mixbus.

For long I wished for a warning sign instead of a blacklist: "This plugin does not meet Ardour's/Mixbus' requirements, use at own risk".
Just to see for myself that it wouldn't run.
But I understand that these plugins probably wouldn't work there anyway.
As an example: After long, Audiodamage's Rough Rider and Axon (the Linux builds) are no longer blacklisted, I can actually see them and load them, but they still make Ardour/Mixbus crash. Same with Vital (haven't checked in a while, but the initial release couldn't open).
And all these plugins work just fine for me in Qtractor, Reaper, Carla, whatever, just not Ardour/Mixbus.

Could there be a way of making the plugin-scanner/blacklist/plugin manager a bit softer on the requirements?

ahellquist

2021-02-09 09:40

reporter   ~0025501

I have always tried to understand the static linking problem and also sort of accepted it, But it is frustrating that all the other vst hosts somehow doesn't have a problem running them.

Is this caused byt the fact that Ardour/Mixbus use the very same libs (with possibly other versions of the libs) internally for their built in plugins ?
In the U-he case, we are talikng of a VST plugin and the built in Ardour plugins are lv2. (do the share evil libs?)

Regardless of the real cause for the blacklisting, This will drive away both plugin developers (the U-he devs seemingly thought Ardour was a trouble) as well as End users
Why use Ardour/Mixbus if my plugin will not work but it works fine in Reaper or Carla or Qtracktor or any other host.

Maybe this is a design problem and it is not solvable ?

ahellquist

2021-02-18 00:10

reporter   ~0025527

The blacklisted Hive beta was fixed a few days after so in this case it was clearly a case of missing static libs..
I don't know if we need a reason for blacklist even if it would be nice to have. Feel free to close this ticket..

Issue History

Date Modified Username Field Change
2021-02-07 18:48 ahellquist New Issue
2021-02-07 18:48 ahellquist Tag Attached: Blacklist
2021-02-07 18:48 ahellquist Tag Attached: u-he
2021-02-07 22:32 x42 Note Added: 0025497
2021-02-09 08:31 thebutant Note Added: 0025500
2021-02-09 09:40 ahellquist Note Added: 0025501
2021-02-18 00:10 ahellquist Note Added: 0025527