View Issue Details

IDCategoryLast Update
0008571bugs2021-02-10 21:51
ReportermusicsaturdaybugAssigned Tox42 
Reproducibilitysometimes 
Status resolvedResolutionno change required 
PlatformApple MacintoshOSMacOSOS Version10.12 or later
Product Version6.5 
Fixed in Version 
Summary0008571: mp3 files exported from ardour 6.5.0 skip when played on iphone
DescriptionHello. This is a strange one.

I record a session in ardour. If I export to a .wav, it plays on all hardware no problem. So for instance, it plays through my mac, on my linux box, on my iphone, etc., without any skips.

Now, when I export the session to any .mp3 format through ardour, it still plays beautifully on all the hardware-- EXCEPT for the iphone. So each time the .mp3 starts on the iphone, there is a skip of a several seconds, and it happens a few times. Only in the begining of the track, like the first 10 seconds. So, if I play the .mp3 on my mac, through itunes or quicktime, it works fine. on my linux box through any media player fine. on my iphone, skips.

OK, here is the very weird part: so i figured i would try to outsmart the system. i took the .wav export of the session, opened it in audacity, and then, in audactiy, saved the .wav to a .mp3. because i presumed there was a problem somehow with how ardour is making the .mp3. well, same exact problem with this .mp3 file. this happens on any .mp3 file that is created either from an ardour session or a .wav of an an ardour session, ONLY on iphone playback. the only way i can get an .mp3 that does not skip is to import the .wav (which is the mastered session file) into garageband, and then export to .mp3. if i do that, it does not skip on iphone.

here is the problem with this issue: its bad for sending files to others who use iphones. you never know if your .mp3 will skip. it may be a problem with apple, but somehow, ardour is triggering it. it only happens with sessions created on ardour. does not happen if i create my mix on garageband and export to mp3 or if i import my ardour .wav to garage band and export to .mp3.

the skip is similar to the old days of CD players when you woudl accidentally shake the player and it would skip. also, important, the .mp3 plays just fine on any other hardware. this only happens on the iphone playback.

any help or ideas?

thanks so much,
a dedicated ardour fan
Steps To Reproduceexport ardour session to .mp3 in ardour.
or, export ardour session to .wav, open in audacity, then save file to .mp3.

play .mp3 on iphone. most times, there will be skips for the first 10 seconds.

only happens with .mp3 generated from audacity or an audacity .wav.

save .mp3s play back fine on all other hardware. only skips on iphone.
Tagsexport, mp3, skip

Activities

musicsaturdaybug

2021-02-10 02:11

reporter   ~0025504

edit: iphone Xs Max, software version 14.3; new - able to repeat also on an ipad

paul

2021-02-10 02:48

administrator   ~0025505

MP3 files on macOS are generated using a system library provided by Apple.

Have you established whether or not any non-Apple software can generate iPhone-compatible mp3 files?

paul

2021-02-10 20:18

administrator   ~0025507

my previous note is incorrect. We use apple libraries to read, but not write/create mp3 files. Sorry for the misinformation.

musicsaturdaybug

2021-02-10 21:48

reporter   ~0025509

i believe this has been solved. i updated my original post on the board as follows, after your advice and the advice of others in the thread:

TLDR: Make sure to export MP3s to be played on iphone/ipad/ios in Constant Bitrate (CBR). There is a setting in the export edit screen to change from Variable Bitrate (VBR) to CBR. You want CBR if you want to avoid the skipping mentioned in this post. CBR at 192 kbs did the trick for me, as suggested by the experts in this thread.

Further, I would like to note that this is not an error or defect in Ardour. No, ardour’s default MP3 export is set to VBR, and the users need to know what settings they need for the hardware they are using. There is tons of information about VBR and CBR and from what I can tell from researching after this experience, any benefits of VBR are outweighed in the fact that many hardware and software systems choke up on VBR for all kinds of reasons. This is why the file would only choke on ios. It was a VBR export. Once I changed it to a CBR at 192, no skips, no problems. Thanks for helping me solve this frustrating problem. Finally, I would like to note that I repeated the solution in audiacity. Indeed, the default export setting in audacity was also VBR. When I took the same .wav file from ardour and exported from audacity at same CBR 192, it was perfect and produced a file the exact same size as ardours file, which makes sense because they both use FFMPEG as the converter. Thus, it is not a problem with ardour, but with a conflict between ios playblack and use of VBR .mp3s. To avoid, use CBR.
Thanks.

Issue History

Date Modified Username Field Change
2021-02-10 01:54 musicsaturdaybug New Issue
2021-02-10 01:54 musicsaturdaybug Tag Attached: export
2021-02-10 01:54 musicsaturdaybug Tag Attached: mp3
2021-02-10 01:54 musicsaturdaybug Tag Attached: skip
2021-02-10 02:11 musicsaturdaybug Note Added: 0025504
2021-02-10 02:48 paul Note Added: 0025505
2021-02-10 20:18 paul Note Added: 0025507
2021-02-10 21:48 musicsaturdaybug Note Added: 0025509
2021-02-10 21:51 x42 Assigned To => x42
2021-02-10 21:51 x42 Status new => resolved
2021-02-10 21:51 x42 Resolution open => no change required