View Issue Details

IDCategoryLast Update
0008670bugs2021-06-19 19:02
ReporternicbeuAssigned Todrobilla 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformGNUOSLinuxOS Version(any)
Product Version6.6 
Fixed in Version 
Summary0008670: OSC message lets ardour quit with segmentation fault
DescriptionIf a foldback bus is selected and you try to select another track by issuing /access_action/Editor/select-next-route or prev-route ardour6 quits with a Speicherzugriffsfehler (german).
Steps To ReproduceArdour OSC factory settings
Sent via TouchOSC:
/set_surface/8/15/24807 f:1
/set_surface/strip_types f:159
/strip/select/8 f:1 which is the foldback bus
/set_surface/32/271/25271 f:3
/access_action/Editor/select-prev-route --> segmentation fault
Additional InformationI'm on
Gentoo (5.10.31)
Ardour 6.6.0
"Desert Island Selection"
(rev 6.6)
Intel 64-bit
Tagsosc

Activities

nicbeu

2021-04-20 19:02

reporter  

ardour6.6_build_configuration.txt (2,891 bytes)
Build documentation: False
Debuggable build: False
Export all symbols (backtrace): False
Install prefix: /usr
Strict compiler flags: []
Internal Shared Libraries: True
Use External Libraries: False
Library exports hidden: True
Free/Demo copy: False

ALSA DBus Reservation: True
Architecture flags: None
ARM NEON support: False
Aubio: True
AudioUnits: False
Build target: x86_64
Canvas Test UI: False
Beatbox test app: False
CoreAudio: False
CoreAudio 10.5 compat: False
Debug RT allocations: False
Debug Symbols: False
Denormal exceptions: False
Dr. Mingw: False
FLAC: True
FPU optimization: True
FPU AVX/FMA support: True
Freedesktop files: True
Libjack linking: link
Libjack metadata: True
Lua Binding Doc: False
Lua Commandline Tool: True
LV2 UI embedding: True
LV2 support: True
LV2 extensions: True
LXVST support: True
Mac VST support: False
NI-Maschine: False
OGG: True
Phone home: False
Process thread timing: False
Program name: Ardour
Samplerate: True
PT format: False
PTW32 Semaphore: False
Threaded WaveViews: True
Translation: True
Unit tests: False
Use LLD linker: False
VST3 support: True
Windows VST support: False
Wiimote support: False
Windows key: Mod4><Super

PortAudio Backend: False
CoreAudio/Midi Backend: False
ALSA Backend: True
Dummy backend: True
JACK Backend: True
Pulseaudio Backend: True

Buildstack: -system-
Mac i386 Architecture: False
Mac ppc Architecture: False
Mac arm64 Architecture: False

C compiler flags: ['-I/var/tmp/portage/media-sound/ardour-6.6-r1/work/Ardour-6.6.0', '-march=native', '-O2', '-pipe', '-lboost_system', '-DHAVE_RF64_RIFF', '-DWAF_BUILD', '-DNDEBUG', '-fshow-column', '-pipe', '-DARCH_X86', '-mmmx', '-msse', '-mfpmath=sse', '-DUSE_XMMINTRIN', '-DBUILD_SSE_OPTIMIZATIONS', '-DLXVST_64BIT', '-Wall', '-Wpointer-arith', '-Wcast-qual', '-Wcast-align', '-Wno-unused-parameter', '-DBOOST_SYSTEM_NO_DEPRECATED', '-D_ISOC9X_SOURCE', '-D_LARGEFILE64_SOURCE', '-D_FILE_OFFSET_BITS=64', '-DPROGRAM_NAME="Ardour"', '-DPROGRAM_VERSION="6"', '-Wstrict-prototypes', '-Wmissing-prototypes']
C++ compiler flags: ['-I/var/tmp/portage/media-sound/ardour-6.6-r1/work/Ardour-6.6.0', '-march=native', '-O2', '-pipe', '-std=c++11', '-lboost_system', '-DHAVE_RF64_RIFF', '-DWAF_BUILD', '-DNDEBUG', '-fshow-column', '-pipe', '-DARCH_X86', '-mmmx', '-msse', '-mfpmath=sse', '-DUSE_XMMINTRIN', '-DBUILD_SSE_OPTIMIZATIONS', '-DLXVST_64BIT', '-Wall', '-Wpointer-arith', '-Wcast-qual', '-Wcast-align', '-Wno-unused-parameter', '-DBOOST_SYSTEM_NO_DEPRECATED', '-D_ISOC9X_SOURCE', '-D_LARGEFILE64_SOURCE', '-D_FILE_OFFSET_BITS=64', '-DPROGRAM_NAME="Ardour"', '-DPROGRAM_VERSION="6"', '-Woverloaded-virtual', '-Wno-unused-local-typedefs', '-D__STDC_LIMIT_MACROS', '-D__STDC_FORMAT_MACROS', '-DCANVAS_COMPATIBILITY', '-DCANVAS_DEBUG', '-DBOOST_ERROR_CODE_HEADER_ONLY']
Linker flags: ['-march=native', '-O2', '-pipe', '-lboost_system', '-Wl,-O1', '-Wl,--as-needed']

nicbeu

2021-04-20 20:00

reporter   ~0025725

gdb's output:
Thread 1 "ArdourGUI" received signal SIGSEGV, Segmentation fault.
0x00007ffff7ae28f8 in void ARDOUR::CoreSelection::select_adjacent_stripable<std::_List_iterator<boost::shared_ptr<ARDOUR::Stripable> > >(bool, bool, std::_List_iterator<boost::shared_ptr<ARDOUR::Stripable> > (std::__cxx11::list<boost::shared_ptr<ARDOUR::Stripable>, std::allocator<boost::shared_ptr<ARDOUR::Stripable> > >::*)(), std::_List_iterator<boost::shared_ptr<ARDOUR::Stripable> > (std::__cxx11::list<boost::shared_ptr<ARDOUR::Stripable>, std::allocator<boost::shared_ptr<ARDOUR::Stripable> > >::*)()) () from /usr/lib64/ardour6/libardour.so.3


Same crash on Mixbus:
Mixbus 6.2.407
(rev 6.2-407-g970ec2cc9)
Intel 64-bit

drobilla

2021-06-18 16:59

developer   ~0025966

Should be fixed in 57a3db06f8

drobilla

2021-06-18 17:01

developer   ~0025967

I tested by manually sending those messages with oscsend, please confirm your TouchOSC workflow doesn't crash anymore.

nicbeu

2021-06-18 23:06

reporter   ~0025969

Built
Ardour 6.7.202
"Desert Island Selection"
(rev 6.7-202-ge7466bddb)
Intel 64-bit

Recreated my workflow and now it works as expected.
Fix confirmed

Thank you very much.

anonymous

2021-06-19 19:02

viewer   ~0025972

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-04-20 19:02 nicbeu New Issue
2021-04-20 19:02 nicbeu Tag Attached: osc
2021-04-20 19:02 nicbeu File Added: ardour6.6_build_configuration.txt
2021-04-20 20:00 nicbeu Note Added: 0025725
2021-06-18 16:59 drobilla Note Added: 0025966
2021-06-18 17:00 drobilla Assigned To => drobilla
2021-06-18 17:01 drobilla Status new => feedback
2021-06-18 17:01 drobilla Note Added: 0025967
2021-06-18 23:06 nicbeu Note Added: 0025969
2021-06-18 23:06 nicbeu Status feedback => assigned
2021-06-19 16:53 drobilla Status assigned => resolved
2021-06-19 16:53 drobilla Resolution open => fixed
2021-06-19 19:02 anonymous Note Added: 0025972
2021-06-19 19:02 anonymous Status resolved => closed