View Issue Details

IDCategoryLast Update
0008725bugs2021-07-26 11:55
ReporterfinottiAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLinuxOSDebianOS VersionUnstable
Product Version6.7 
Fixed in Version 
Summary0008725: MIDI Import Problem
DescriptionWhen trying to import a (specific) MIDI file, the result is different of the original.
Steps To ReproduceSimply import the AeC.mid attached. You will see some overlapped notes (and some long stretched notes) not present in the original. (See Screen.png attached.)
Additional InformationOpening the file in Muse 4 shows the correct notes. The original file was broken in two regions (split at the 14th bar). After merging these two regions I could import it into Ardour without the problem. (I believe the original MIDI file was create using Encore on a Mac.)
TagsMidi

Activities

finotti

2021-05-27 11:55

reporter  

AeC.mid (7,865 bytes)
Screen.png (153,008 bytes)
Screen.png (153,008 bytes)

paul

2021-06-27 22:19

administrator   ~0026014

The MIDI file contains two consecutive NoteOn events for note number 61 at pulse 92 and 96. This is technically illegal in the MIDI specification, and the behaviour is undefined.

Ardour's chosen behavior is to match each following NoteOff with the earliest unresolved NoteOn, so the NoteOff at pulse 96.45 is used to resolve the NoteOn at pulse 92.

Apparently this is not what Encore or Muse 4 expect or do, and they probably treat a second NoteOn with no intervening NoteOff as an implicit NoteOff.

paul

2021-06-28 14:19

administrator   ~0026015

In fact, this file is full of NoteOn(N),NoteOn(N),NoteOff(N) patterns, for many different pitch values. It is essentially completely corrupt by normal MIDI standards, but is handled OK by other software that ignore these errors (I checked Reaper too, which handles it fine).

paul

2021-06-28 15:02

administrator   ~0026016

Anyway, the next release will contain a fix (commit 5c3e5f9afb4ab)

anonymous

2021-07-26 11:55

viewer   ~0026081

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-05-27 11:55 finotti New Issue
2021-05-27 11:55 finotti Tag Attached: Midi
2021-05-27 11:55 finotti File Added: AeC.mid
2021-05-27 11:55 finotti File Added: Screen.png
2021-06-27 22:19 paul Note Added: 0026014
2021-06-28 14:19 paul Note Added: 0026015
2021-06-28 15:02 paul Note Added: 0026016
2021-06-28 15:02 paul Assigned To => paul
2021-06-28 15:02 paul Status new => resolved
2021-06-28 15:02 paul Resolution open => fixed
2021-07-26 11:55 anonymous Note Added: 0026081
2021-07-26 11:55 anonymous Status resolved => closed