View Issue Details

IDCategoryLast Update
0008740bugs2021-08-11 11:22
ReportererojahnAssigned Topaul 
Reproducibilityalways 
Status closedResolutionnot fixable 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.7 
Fixed in Version 
Summary0008740: Regionlength is not adjustable precisely
DescriptionI have this problem a lot as i work with duplicating regions pretty often. When i set the length of a region to fit to the grid (even if i have the setting to the snap to grid only set) it will not be the right length. So when i duplicate the region a few times it moves off the grid. This is introducing phasing issues to hihats and makes it impossible to layer them cleanly.
Also when this happens and i have set the settings so the regions i move will snap to other regions ends or beginnings(which i find really usefull) it will move the region off the grid very often. This makes it unpredictable where i place the sounds.

On the pictures its possible to see, that the regionlength should be 1 bar but when i duplicate it a lot of times it moves off.
Steps To ReproduceJust set a regions length by snapping to grid and duplicate.
Tagsediting, loop, region

Relationships

duplicate of 0007786 new "Duplicate Region - Fill Track" does not align exactly at beat raster 

Activities

erojahn

2021-06-12 11:21

reporter  

Bugregionlength.png (41,832 bytes)
Bugregionlength.png (41,832 bytes)
Seetheregionlength.png (27,794 bytes)
Seetheregionlength.png (27,794 bytes)

mikelupe

2021-06-12 13:07

reporter   ~0025942

Maybe it's not the same issue, but I had similar problems which I resolved through disciplining myself _strongly_ to always switch snapping to "bar" when creating, resizing or moving regions around.

Often I created or resized regions in a wide zoom mode, which didn't allow me to see I was short of e.g. 1/64. So when duplicating 7 times, the same thing happened to me: the last region was short for 8*1/64 = 1/8. Duplicating these 8 bars again for sure created total chaos, not only phasing issues :)

Or is it another issue?

erojahn

2021-06-12 16:03

reporter   ~0025948

I think this could be another issue. I have snapping enabled all the time and even when i zoom in to the max i cant see the region being not the right size. Also the length seems to be: 001|00|0000 yet it still after a few duplications gets bigger... What do you mean with snapping to "bar"? Should i set the grid to a bar? :)

mikelupe

2021-06-12 21:00

reporter   ~0025949

Yes, I meant grid to "bar" :)

But it seems it indeed isn't the same issue, as it apparently is about the rounding issue, which the devs say will be solved in Ardour 7.x.

paul

2021-06-22 21:53

administrator   ~0025996

not fixable until v7 or later

anonymous

2021-08-11 11:22

viewer   ~0026101

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-06-12 11:21 erojahn New Issue
2021-06-12 11:21 erojahn Tag Attached: editing
2021-06-12 11:21 erojahn Tag Attached: loop
2021-06-12 11:21 erojahn Tag Attached: region
2021-06-12 11:21 erojahn File Added: Bugregionlength.png
2021-06-12 11:21 erojahn File Added: Seetheregionlength.png
2021-06-12 13:07 mikelupe Note Added: 0025942
2021-06-12 13:22 x42 Relationship added duplicate of 0007786
2021-06-12 16:03 erojahn Note Added: 0025948
2021-06-12 21:00 mikelupe Note Added: 0025949
2021-06-22 21:53 paul Assigned To => paul
2021-06-22 21:53 paul Status new => resolved
2021-06-22 21:53 paul Resolution open => not fixable
2021-06-22 21:53 paul Note Added: 0025996
2021-08-11 11:22 anonymous Note Added: 0026101
2021-08-11 11:22 anonymous Status resolved => closed