View Issue Details

IDCategoryLast Update
0008741bugs2021-08-11 22:04
ReportergraymonAssigned Topaul 
Reproducibilityalways 
Status closedResolutionno change required 
PlatformLinuxOSFedora 34OS Version5.12.9-300.fc34.
Product Version6.7 
Fixed in Version 
Summary0008741: Ardour 6.7 hangs after project is loaded
DescriptionArdour 6.7 linux hangs on Fedora 34. I just updated from 33 where it worked okay.
Steps To ReproduceLaunch Ardour. Select project from list. Project loads. After first mouse click on project - it hangs.

Please let me know if you need more information. I'm not sure what else I can contribute?
Additional InformationI ran strace Ardour6, and this messaging repeats:

recvmsg(7, {msg_namelen=0}, 0) = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(7, {msg_namelen=0}, 0) = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(7, {msg_namelen=0}, 0) = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(7, {msg_namelen=0}, 0) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN}, {fd=7, events=POLLIN}, {fd=5, events=POLLIN|POLLPRI}, {fd=10, events=0}], 4, 0) = 0 (Timeout)
read(4, 0x7ffff42edf90, 16) = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(7, {msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="\4\1#?\215f^\4\346\0\0\0\247\3\340\0\0\0\0\0\4\4\331\0\4\4\224\0\20\0\1\0", iov_len=4096}], msg_iovlen=1, msg_controllen=0, msg_flags=0}, 0) = 32
recvmsg(7, {msg_namelen=0}, 0) = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(7, {msg_namelen=0}, 0) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=7, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=7, revents=POLLOUT}])
writev(7, [{iov_base="\24\0\6\0\346\0\0\0q\1\0\0!\0\0\0\0\0\0\0\377\377\377\377", iov_len=24}, {iov_base=NULL, iov_len=0}, {iov_base="", iov_len=0}], 3) = 24
poll([{fd=7, events=POLLIN}], 1, -1) = 1 ([{fd=7, revents=POLLIN}])
recvmsg(7, {msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="\1 $?\1\0\0\0!\0\0\0\0\0\0\0\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., iov_len=4096}], msg_iovlen=1, msg_controllen=0, msg_flags=0}, 0) = 36
TagsNo tags attached.

Activities

x42

2021-06-12 22:14

administrator   ~0025950

Are you using pipewire? maybe related to https://tracker.ardour.org/view.php?id=8738 which is apparently fixed since pipewire v0.3.30.

Does this also happen when you disable pipewire and use Ardour/ALSA (no JACK)?

graymon

2021-06-19 23:27

reporter   ~0025973

Ardour functions correctly with ALSA. When you open a project, the first thing you need to do is change the audio to ALSA, or it will hang.

PulseAudio and PipeWire don't work. The UI freezes immediately. I did not try jack. I replaced pipewire with pulseaudio. When I open a project, change to ALSA - it works. then change to pulseaudio, start pulseaudio, ardour hangs. I guess I'll test it again with a new release of pipewire or pulseaudio or ardour:

kernel 5.12.11-300.fc34.x86_64
alsa-lib-1.2.5.1-1.fc34.x86_64
pipewire-0.3.30-2.fc34.x86_64
pulseaudio-14.2-3.fc34.x86_64
Ardour-6.7.200-x86_64-gcc5.run (nightly)

paul

2021-06-22 21:52

administrator   ~0025995

pipewire issues.

anonymous

2021-08-11 22:04

viewer   ~0026102

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-06-12 22:04 graymon New Issue
2021-06-12 22:14 x42 Note Added: 0025950
2021-06-12 23:12 x42 Status new => feedback
2021-06-19 23:27 graymon Note Added: 0025973
2021-06-19 23:27 graymon Status feedback => new
2021-06-22 21:52 paul Assigned To => paul
2021-06-22 21:52 paul Status new => resolved
2021-06-22 21:52 paul Resolution open => no change required
2021-06-22 21:52 paul Note Added: 0025995
2021-08-11 22:04 anonymous Note Added: 0026102
2021-08-11 22:04 anonymous Status resolved => closed