View Issue Details

IDCategoryLast Update
0008743bugs2021-08-13 12:09
ReporterDonJaimeAssigned Tox42 
Reproducibilityrandom 
Status closedResolutionfixed 
PlatformArchOSLinuxOS Version(any)
Product Version6.7 
Fixed in Version 
Summary0008743: Track patch selector causes unwanted program change
DescriptionThe patch selector accessible by right-click on a track cannot be disabled. Sometimes this leads to a synthesiser preset being chosen when this is not wanted, as reported at https://discourse.ardour.org/t/losing-synths-patches/88370.

A work-around is to insert a MIDI even filter plugin blocking programme changes, but it would be better if the selector only did anything after being explicitly activated.
Steps To ReproduceUse ZynAddSubFX for long enough and it's likely to crop up some time.
TagsNo tags attached.

Activities

.again

2021-07-12 19:52

reporter   ~0026049

i experience the same problem. Is there a workaround?

x42

2021-07-13 01:30

administrator   ~0026050

Ardour 6.8-130-gab6d46c24c now has a checkbox in the MIDI track's context menu to disable re-playing patch changes when loading a session.

.again

2021-07-13 06:12

reporter   ~0026051

Nice. Tested it and it works. Thanks.

anonymous

2021-08-13 12:09

viewer   ~0026104

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-06-14 12:09 DonJaime New Issue
2021-07-12 19:52 .again Note Added: 0026049
2021-07-13 01:30 x42 Assigned To => x42
2021-07-13 01:30 x42 Status new => resolved
2021-07-13 01:30 x42 Resolution open => fixed
2021-07-13 01:30 x42 Note Added: 0026050
2021-07-13 06:12 .again Note Added: 0026051
2021-08-13 12:09 anonymous Note Added: 0026104
2021-08-13 12:09 anonymous Status resolved => closed