View Issue Details

IDCategoryLast Update
0008755bugs2021-08-19 20:18
ReportermvondrAssigned Topaul 
Reproducibilityalways 
Status closedResolutionno change required 
PlatformMicrosoftOSWindowsOS Version10
Product Version6.7 
Fixed in Version 
Summary0008755: Compressor plugin causes system crash
DescriptionTrying to see GUI of ACE Compressor (stereo) plugin, Ardour is exited.
Steps To ReproduceOn Windows 10, Ardour 6.7
- Create audio track (mono/stereo)
- Add plugin ACE Compressor (stereo) (or other LV2!)
- Double click on plugin to see GUI in the separate window
Ardour is hang up and is exited.
TagsACEplugins, ardour6, crash, plugin, Windows

Activities

x42

2021-06-20 22:35

administrator   ~0025975

This is commonly caused by outdated graphics card drivers, and solved by updating the graphics card driver to the latest version.

Other plugins that use openGL (e.g. Harrison XT-*, overtoneDSP) are likely affected as well.

mvondr

2021-06-21 10:54

reporter   ~0025983

I have all drivers and Windows on latest versions. I updates it regularly. And the laptop is only 3 years old (Lenovo E580). All plugins have worked well until some date. Now it is very frustrating and anoying and makes Ardour hard usable.

paul

2021-06-22 21:58

administrator   ~0025999

To be clear, this is an issue with OpenGL on your system, not with Ardour. OpenGL on Windows is a part of the graphics card driver.

Hans Flikkema

2021-06-24 16:56

reporter   ~0026005

How can I check if my computers uses OpenGL. I think I experience the same problems with 6.7 (crashing all the time so I had to reinstall 6.6.346)
I experience the answers given above not very helpfull, with all respect.

paul

2021-06-24 20:24

administrator   ~0026006

Theses plugins use OpenGL for their GUIs. Windows graphics hardware drivers provides OpenGL. It's not always functional.

mvondr

2021-06-26 17:56

reporter   ~0026011

I have solved this problem on my Lenovo E580. I setup graphic preference to Radeon GPU and it works well! So it means, problem is with last update of Intel UHD Graphics 620 drivers (version: 27.20.100.9466).
Steps:
1. Open Windows Settings, type "graphic", choose Graphic Settings,
2. Click Browse, find your Ardour.lnk (or .exe) to add it
3. Click on the new item Ardour.exe, click Options, select Graphic preference High Performance GPU: Radeon RX 550.

Until Intel make functional update, this is the workaround.

Hans Flikkema

2021-06-26 22:23

reporter   ~0026013

Hi, thanks so much mvondr
The action described by mvondr (2021-06-26 17:56) seems to have solved mine problem as well (I run Ardour W10 PRO on LENOVO Ideacentre).
1. Opened Windows Settings, type and choose Graphic Settings,
2. Browse, find your Ardour.exe to add it
3. Click on the new item Ardour.exe, click Options, select Graphic preference High Performance GPU: NVIDIA GeForce GT-730.
Up to this moment no crashing :-)

anonymous

2021-08-19 20:18

viewer   ~0026118

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-06-20 20:17 mvondr New Issue
2021-06-20 20:17 mvondr Tag Attached: ACEplugins
2021-06-20 20:17 mvondr Tag Attached: ardour6
2021-06-20 20:17 mvondr Tag Attached: crash
2021-06-20 20:17 mvondr Tag Attached: plugin
2021-06-20 20:17 mvondr Tag Attached: Windows
2021-06-20 22:35 x42 Note Added: 0025975
2021-06-21 10:54 mvondr Note Added: 0025983
2021-06-22 21:58 paul Note Added: 0025999
2021-06-24 16:56 Hans Flikkema Note Added: 0026005
2021-06-24 20:24 paul Note Added: 0026006
2021-06-26 17:56 mvondr Note Added: 0026011
2021-06-26 20:09 paul Assigned To => paul
2021-06-26 20:09 paul Status new => resolved
2021-06-26 20:09 paul Resolution open => no change required
2021-06-26 22:23 Hans Flikkema Note Added: 0026013
2021-08-19 20:18 anonymous Note Added: 0026118
2021-08-19 20:18 anonymous Status resolved => closed