View Issue Details

IDCategoryLast Update
0008802bugs2021-11-26 07:01
Reporter.againAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformArchOSLinuxOS Version(any)
Product VersionMixbus 7.x 
Fixed in Version 
Summary0008802: Building with --no-nls fails
Descriptionbuilding with following configuration breaks the build.

waf configure \
    --prefix=$PWD/out \
    --configdir=$PWD/out/etc \
    --cxx11 \
    --debug-symbols \
    --fpu-optimization \
    --freedesktop \
    --lxvst \
    --no-nls \
    --no-phone-home \
    --no-windows-vst \
    --use-external-libs \
    --vst3 \
    --with-backends="jack"

when i remove the --no-nls option things run fine.
Steps To Reproduce- setup build configuration
waf configure \
    --prefix=$PWD/out \
    --configdir=$PWD/out/etc \
    --cxx11 \
    --debug-symbols \
    --fpu-optimization \
    --freedesktop \
    --lxvst \
    --no-nls \
    --no-phone-home \
    --no-windows-vst \
    --use-external-libs \
    --vst3 \
    --with-backends="jack"
- start build with waf build -j2
Additional InformationWaf: Entering directory `/home/michi/work/audio/src/ardour/build'
Git version: 7.0-pre0-1015-g8eec590230

Writing revision info to libs/ardour/revision.cc using 7.0-pre0-1015-g8eec590230, 2021-09-27
Generating po/de.po
Generating po/eu.po
Generating po/it.po
Generating po/ja.po
Generating po/ru.po
Generating po/zh.po
Generating po/fr.po
Generating po/ko.po
Generating /home/michi/work/audio/src/ardour/gtk2_ardour/ardour.appdata.xml.in
[ 63/1107] Compiling libs/temporal/timeline.cc
[ 64/1107] Compiling libs/temporal/tempo.cc
[ 87/1107] Linking build/libs/lua/libliblua.a
[ 89/1107] Linking build/libs/ptformat/libptformat.so
[ 90/1107] Compiling libs/midi++2/parser.cc
[ 92/1107] Compiling libs/midi++2/ipmidi_port.cc
[ 93/1107] Compiling libs/midi++2/midi.cc
[ 94/1107] Compiling libs/midi++2/channel.cc
[ 96/1107] Compiling libs/midi++2/mmc.cc
[ 97/1107] Compiling libs/midi++2/mtc.cc
[ 98/1107] Compiling libs/audiographer/src/general/normalizer.cc
[ 99/1107] Compiling libs/audiographer/src/general/loudness_reader.cc
[ 100/1107] Compiling libs/audiographer/src/general/sr_converter.cc
[ 101/1107] Compiling libs/audiographer/src/general/limiter.cc
[ 102/1107] Compiling libs/audiographer/src/routines.cc
[ 103/1107] Compiling libs/audiographer/src/debug_utils.cc
[ 104/1107] Compiling libs/audiographer/src/general/demo_noise.cc
[ 105/1107] Compiling libs/audiographer/src/general/analyser.cc
[ 106/1107] Compiling libs/audiographer/private/gdither/gdither.cc
[ 107/1107] Compiling libs/audiographer/src/general/broadcast_info.cc
[ 108/1107] Compiling libs/audiographer/private/limiter/limiter.cc
In file included from ../libs/pbd/pbd/i18n.h:24,
                 from ../libs/temporal/timeline.cc:27:
../libs/pbd/gettext.h:58:27: error: expected unqualified-id before ‘const’
   58 | # define gettext(Msgid) ((const char *) (Msgid))
      | ^~~~~
../libs/pbd/gettext.h:58:27: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:58:27: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:59:40: error: expected unqualified-id before ‘const’
   59 | # define dgettext(Domainname, Msgid) ((const char *) (Msgid))
      | ^~~~~
../libs/pbd/gettext.h:59:40: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:59:40: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:60:51: error: expected unqualified-id before ‘const’
   60 | # define dcgettext(Domainname, Msgid, Category) ((const char *) (Msgid))
      | ^~~~~
../libs/pbd/gettext.h:60:51: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:60:51: error: expected ‘)’ before ‘const’
/usr/include/libintl.h:61:14: error: expected unqualified-id before ‘unsigned’
   61 | extern char *ngettext (const char *__msgid1, const char *__msgid2,
      | ^~~~~~~~
/usr/include/libintl.h:61:14: error: expected ‘)’ before ‘unsigned’
../libs/pbd/gettext.h:62:6: note: to match this ‘(’
   62 | ((N) == 1 ? (const char *) (Msgid1) : (const char *) (Msgid2))
      | ^
/usr/include/libintl.h:61:14: error: expected ‘)’ before ‘unsigned’
   61 | extern char *ngettext (const char *__msgid1, const char *__msgid2,
      | ^~~~~~~~
../libs/pbd/gettext.h:62:5: note: to match this ‘(’
   62 | ((N) == 1 ? (const char *) (Msgid1) : (const char *) (Msgid2))
      | ^
/usr/include/libintl.h:67:14: error: expected unqualified-id before ‘unsigned’
   67 | extern char *dngettext (const char *__domainname, const char *__msgid1,
      | ^~~~~~~~~
/usr/include/libintl.h:67:14: error: expected ‘)’ before ‘unsigned’
../libs/pbd/gettext.h:64:6: note: to match this ‘(’
   64 | ((N) == 1 ? (const char *) (Msgid1) : (const char *) (Msgid2))
      | ^
/usr/include/libintl.h:67:14: error: expected ‘)’ before ‘unsigned’
   67 | extern char *dngettext (const char *__domainname, const char *__msgid1,
      | ^~~~~~~~~
../libs/pbd/gettext.h:64:5: note: to match this ‘(’
   64 | ((N) == 1 ? (const char *) (Msgid1) : (const char *) (Msgid2))
      | ^
/usr/include/libintl.h:73:14: error: expected unqualified-id before ‘unsigned’
   73 | extern char *dcngettext (const char *__domainname, const char *__msgid1,
      | ^~~~~~~~~~
/usr/include/libintl.h:73:14: error: expected ‘)’ before ‘unsigned’
../libs/pbd/gettext.h:66:6: note: to match this ‘(’
   66 | ((N) == 1 ? (const char *) (Msgid1) : (const char *) (Msgid2))
      | ^
/usr/include/libintl.h:73:14: error: expected ‘)’ before ‘unsigned’
   73 | extern char *dcngettext (const char *__domainname, const char *__msgid1,
      | ^~~~~~~~~~
../libs/pbd/gettext.h:66:5: note: to match this ‘(’
   66 | ((N) == 1 ? (const char *) (Msgid1) : (const char *) (Msgid2))
      | ^
../libs/pbd/gettext.h:67:35: error: expected unqualified-id before ‘const’
   67 | # define textdomain(Domainname) ((const char *) (Domainname))
      | ^~~~~
../libs/pbd/gettext.h:67:35: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:67:35: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:68:48: error: expected unqualified-id before ‘const’
   68 | # define bindtextdomain(Domainname, Dirname) ((const char *) (Dirname))
      | ^~~~~
../libs/pbd/gettext.h:68:48: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:68:48: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:69:57: error: expected unqualified-id before ‘const’
   69 | # define bind_textdomain_codeset(Domainname, Codeset) ((const char *) (Codeset))
      | ^~~~~
../libs/pbd/gettext.h:69:57: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:69:57: error: expected ‘)’ before ‘const’
In file included from /usr/include/glib-2.0/glib/gthread.h:32,
                 from /usr/include/glib-2.0/glib/gasyncqueue.h:32,
                 from /usr/include/glib-2.0/glib.h:32,
                 from /usr/include/glibmm-2.4/glibmm/threads.h:30,
                 from ../libs/pbd/pbd/signals.h:34,
                 from ../libs/pbd/pbd/transmitter.h:25,
                 from ../libs/pbd/pbd/error.h:22,
                 from ../libs/temporal/timeline.cc:25:
../libs/pbd/pbd/stateful.h: In member function ‘bool PBD::Stateful::property_changes_suspended() const’:
/usr/include/glib-2.0/glib/gatomic.h:96:20: warning: cast from type ‘const gint*’ {aka ‘const int*’} to type ‘gint*’ {aka ‘int*’} casts away qualifiers [-Wcast-qual]
   96 | __atomic_load ((gint *)(atomic), &gaig_temp, __ATOMIC_SEQ_CST); \
      | ^~~~~~~~~~~~~~~~
../libs/pbd/pbd/stateful.h:108:58: note: in expansion of macro ‘g_atomic_int_get’
  108 | bool property_changes_suspended() const { return g_atomic_int_get (&_stateful_frozen) > 0; }
      | ^~~~~~~~~~~~~~~~

../libs/temporal/tempo.cc:743:2: warning: #warning paul tempo_map::set_time_domain needs implementing [-Wcpp]
  743 | #warning paul tempo_map::set_time_domain needs implementing
      | ^~~~~~~
In file included from /usr/include/glib-2.0/glib/gthread.h:32,
                 from /usr/include/glib-2.0/glib/gasyncqueue.h:32,
                 from /usr/include/glib-2.0/glib.h:32,
                 from /usr/include/glibmm-2.4/glibmm/threads.h:30,
                 from ../libs/pbd/pbd/signals.h:34,
                 from ../libs/pbd/pbd/transmitter.h:25,
                 from ../libs/pbd/pbd/error.h:22,
                 from ../libs/temporal/tempo.cc:24:
../libs/pbd/pbd/stateful.h: In member function ‘bool PBD::Stateful::property_changes_suspended() const’:
/usr/include/glib-2.0/glib/gatomic.h:96:20: warning: cast from type ‘const gint*’ {aka ‘const int*’} to type ‘gint*’ {aka ‘int*’} casts away qualifiers [-Wcast-qual]
   96 | __atomic_load ((gint *)(atomic), &gaig_temp, __ATOMIC_SEQ_CST); \
      | ^~~~~~~~~~~~~~~~
../libs/pbd/pbd/stateful.h:108:58: note: in expansion of macro ‘g_atomic_int_get’
  108 | bool property_changes_suspended() const { return g_atomic_int_get (&_stateful_frozen) > 0; }
      | ^~~~~~~~~~~~~~~~
In file included from ../libs/pbd/pbd/i18n.h:24,
                 from ../libs/temporal/tempo.cc:25:
/usr/include/libintl.h: At global scope:
../libs/pbd/gettext.h:58:27: error: expected unqualified-id before ‘const’
   58 | # define gettext(Msgid) ((const char *) (Msgid))
      | ^~~~~
../libs/pbd/gettext.h:58:27: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:58:27: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:59:40: error: expected unqualified-id before ‘const’
   59 | # define dgettext(Domainname, Msgid) ((const char *) (Msgid))
      | ^~~~~
../libs/pbd/gettext.h:59:40: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:59:40: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:60:51: error: expected unqualified-id before ‘const’
   60 | # define dcgettext(Domainname, Msgid, Category) ((const char *) (Msgid))
      | ^~~~~
../libs/pbd/gettext.h:60:51: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:60:51: error: expected ‘)’ before ‘const’
/usr/include/libintl.h:61:14: error: expected unqualified-id before ‘unsigned’
   61 | extern char *ngettext (const char *__msgid1, const char *__msgid2,
      | ^~~~~~~~
/usr/include/libintl.h:61:14: error: expected ‘)’ before ‘unsigned’
../libs/pbd/gettext.h:62:6: note: to match this ‘(’
   62 | ((N) == 1 ? (const char *) (Msgid1) : (const char *) (Msgid2))
      | ^
/usr/include/libintl.h:61:14: error: expected ‘)’ before ‘unsigned’
   61 | extern char *ngettext (const char *__msgid1, const char *__msgid2,
      | ^~~~~~~~
../libs/pbd/gettext.h:62:5: note: to match this ‘(’
   62 | ((N) == 1 ? (const char *) (Msgid1) : (const char *) (Msgid2))
      | ^
/usr/include/libintl.h:67:14: error: expected unqualified-id before ‘unsigned’
   67 | extern char *dngettext (const char *__domainname, const char *__msgid1,
      | ^~~~~~~~~
/usr/include/libintl.h:67:14: error: expected ‘)’ before ‘unsigned’
../libs/pbd/gettext.h:64:6: note: to match this ‘(’
   64 | ((N) == 1 ? (const char *) (Msgid1) : (const char *) (Msgid2))
      | ^
/usr/include/libintl.h:67:14: error: expected ‘)’ before ‘unsigned’
   67 | extern char *dngettext (const char *__domainname, const char *__msgid1,
      | ^~~~~~~~~
../libs/pbd/gettext.h:64:5: note: to match this ‘(’
   64 | ((N) == 1 ? (const char *) (Msgid1) : (const char *) (Msgid2))
      | ^
/usr/include/libintl.h:73:14: error: expected unqualified-id before ‘unsigned’
   73 | extern char *dcngettext (const char *__domainname, const char *__msgid1,
      | ^~~~~~~~~~
/usr/include/libintl.h:73:14: error: expected ‘)’ before ‘unsigned’
../libs/pbd/gettext.h:66:6: note: to match this ‘(’
   66 | ((N) == 1 ? (const char *) (Msgid1) : (const char *) (Msgid2))
      | ^
/usr/include/libintl.h:73:14: error: expected ‘)’ before ‘unsigned’
   73 | extern char *dcngettext (const char *__domainname, const char *__msgid1,
      | ^~~~~~~~~~
../libs/pbd/gettext.h:66:5: note: to match this ‘(’
   66 | ((N) == 1 ? (const char *) (Msgid1) : (const char *) (Msgid2))
      | ^
../libs/pbd/gettext.h:67:35: error: expected unqualified-id before ‘const’
   67 | # define textdomain(Domainname) ((const char *) (Domainname))
      | ^~~~~
../libs/pbd/gettext.h:67:35: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:67:35: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:68:48: error: expected unqualified-id before ‘const’
   68 | # define bindtextdomain(Domainname, Dirname) ((const char *) (Dirname))
      | ^~~~~
../libs/pbd/gettext.h:68:48: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:68:48: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:69:57: error: expected unqualified-id before ‘const’
   69 | # define bind_textdomain_codeset(Domainname, Codeset) ((const char *) (Codeset))
      | ^~~~~
../libs/pbd/gettext.h:69:57: error: expected ‘)’ before ‘const’
../libs/pbd/gettext.h:69:57: error: expected ‘)’ before ‘const’
../libs/temporal/tempo.cc:3110:1: warning: ‘bool bbt_time_to_string(const Temporal::BBT_Time&, std::string&)’ defined but not used [-Wunused-function]
 3110 | bbt_time_to_string (const BBT_Time& bbt, std::string& str)
      | ^~~~~~~~~~~~~~~~~~

In file included from /usr/include/c++/11.1.0/cassert:44,
                 from ../libs/ardour/ardour/chan_count.h:25,
                 from ../libs/ardour/ardour/types.h:55,
                 from ../libs/ardour/ardour/export_analysis.h:27,
                 from ../libs/audiographer/audiographer/general/analyser.h:24,
                 from ../libs/audiographer/src/general/analyser.cc:19:
../libs/audiographer/src/general/analyser.cc: In member function ‘virtual void AudioGrapher::Analyser::process(const AudioGrapher::ProcessContext<float>&)’:
../libs/audiographer/src/general/analyser.cc:139:43: warning: comparison of integer expressions of different signedness: ‘const samplecnt_t’ {aka ‘const long int’} and ‘long unsigned int’ [-Wsign-compare]
  139 | assert (pbin >= 0 && pbin < (sizeof (_result.peaks) / sizeof (ARDOUR::PeakData::PeakDatum) / 4));
      | ~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../libs/audiographer/src/general/analyser.cc:167:53: warning: comparison of integer expressions of different signedness: ‘AudioGrapher::samplecnt_t’ {aka ‘long int’} and ‘long unsigned int’ [-Wsign-compare]
  167 | assert (p >= 0 && p < (sizeof (_result.lgraph_i) / sizeof(float)));
      | ~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Waf: Leaving directory `/home/michi/work/audio/src/ardour/build'
Build failed
 -> task in 'libtemporal' failed with exit status 1 (run with -v to display more information)
 -> task in 'libtemporal' failed with exit status 1 (run with -v to display more information)
TagsNo tags attached.

Activities

x42

2021-09-27 14:31

administrator   ~0026166

Fixed in 7.0-pre0-1010-g0dcf7d54e5

anonymous

2021-11-26 07:01

viewer   ~0026246

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-09-27 07:01 .again New Issue
2021-09-27 14:31 x42 Assigned To => x42
2021-09-27 14:31 x42 Status new => resolved
2021-09-27 14:31 x42 Resolution open => fixed
2021-09-27 14:31 x42 Note Added: 0026166
2021-11-26 07:01 anonymous Note Added: 0026246
2021-11-26 07:01 anonymous Status resolved => closed